#5015·portainer

invalid format for cron message when it's valid

Author: codeagencybeCreated Apr 27, 2021Updated Sep 11, 2026
Labelskind/bugbug/confirmedinternal/jira

Bug description Error message about invalid format for CRON in the Edge job details When you choose Advanced Configuration and type in something straight forward as 0 */2 * * * for every 2 hours, it returns an orange error message " This field format is invalid."

When you change to Basic Configuration and select "every 2 hours" from the dropdown and save it, re-open, change to Advanced Configuration, now the fields shows..... 0 */2 * * * exactly the same as above but no error. Unless you make a change, it throws the error again.

No breaking or blocking bug, just an confusing inconvenience

Expected behavior Don't show this format validation error when the format is actually correct

Steps to reproduce the issue:

  1. create an edge job
  2. change to Advanced
  3. type in any regular CRON expression like 0 */2 * * * or 0 */6 * * *
  4. format invalid message will appear, no matter what you enter
  5. change to Basic
  6. select every 2 hours from the dropdown
  7. save the edge job
  8. edit the edge job
  9. change back Advanced
  10. Portainer now shows the previous selection from dropdown as CRON expression exactly how you typed in first attempt without error message
  11. Try make a simple change
  12. Error message comes back

Technical details:

  • Portainer version: 2.11 CE
  • Docker version (managed by Portainer): Docker version 20.10.6, build 370c289
  • Platform (windows/linux): Ubuntu
  • Command used to start Portainer (docker run -p 9000:9000 portainer/portainer): Docker compose, Docker standalone
  • Browser: Chrome, Brave, Opera, Edge
  • Have you reviewed our technical documentation and knowledge base? Yes

image