#13264·portainer

pulling from custom registry credentials are ignored

Author: felixlabrotCreated Aug 15, 2026Updated Sep 11, 2026
Labelskind/bugbug/need-confirmationDocs issue not neededQE Pending Reviewlts-backport3 - Mediumbot/triage-completerelease/3.0.0

Before you start please confirm the following.

  • Yes, I've searched similar issues on GitHub.
  • Yes, I've checked whether this issue is covered in the Portainer documentation.

Problem Description

When pulling from a custom registry as a non global admin user, a fake error is shown which claims there are no basic auth credentials for this registry available. The registry is properly configured, but Portainer refuses to use those credentials when a non-admin user is logged in.

Expected Behavior

The images should be pulled.

Actual Behavior

When attempting to pull from a custom registry the fake error Failed to pull images of the stack: compose pull operation failed: Error response from daemon: Head "https://registry.something.com/v2/someproject/backend/manifests/latest": no basic auth credentials is shown. It is not being attempted to pull from the registry.

Steps to Reproduce

  1. Log in as any non-admin user.
  2. Pull any image from a custom registry which needs credentials to login and the credentials are configured by an admin.
  3. observe Portainer lying

Portainer logs or screenshots

No response

Portainer version

2.39.6

Portainer Edition

Business Edition (BE/EE) with 5NF / 3NF license

Platform and Version

Docker version 29.5.3, build d1c06ef

OS and Architecture

VMware Photon OS 5.0

Browser

No response

What command did you use to deploy Portainer?

bash

Additional Information

@Nick-Portainer This is exactly bug #12551 reintroduced after it already had been fixed.