#7158·rethinkdb

从集群中删除节点失败

作者: LeonidDubrovin创建于 2024年11月13日更新于 2024年11月13日

我正在尝试从集群中删除服务器。为此,我先停止数据库,然后删除 rethinkdb 数据,并使用另一个配置文件启动数据库,其中不包含 join 和 canonical-address 参数。在正在清理数据库的服务器上,我收到了以下消息: `warn: 远程节点拒绝与我们连接,对端: 192.168.138.168:51556,原因: "意外的服务器 ID (实际: abd2571e-699e-4dbd-9f8e-5e7f9641def1,预期: dc708f19-f38b-4247-9d27-743f28930078)"` 在另一台服务器上,我收到了以下消息: `warn: 来自 192.168.138.165:29015 的连接尝试失败,原因: 意外的服务器 ID (实际: abd2571e-699e-4dbd-9f8e-5e7f9641def1,预期: dc708f19-f38b-4247-9d27-743f28930078)` 如何正确从集群中删除节点?

内容来源: rethinkdb/rethinkdb