使用 eBPF 处理不存在的 pod 的数据包
作者: sfudeus创建于 2026年8月19日更新于 2026年9月19日
标签stale
< !--- 提供一个总体的问题概述,放在上面的标题中 --> < !--- 如果您认为问题可能涉及安全问题,请将其报告为漏洞 --> < !--- 报告漏洞: https://GitHub.com/projectcalico/calico/security --> 在向不存在的 pod IP 发送数据包(例如执行 curl 请求)时,Calico eBPF 行为会根据目标 pod 所在的位置(即在哪个主机子网中)而有所不同。 向一个不存在的 IP 地址发送流量,curl 请求会失败,如下所示
- 正在尝试连接 100.66.39.2:80 ... * 连接失败,因为 100.66.39.2: 无效参数 * 连接到 100.66.39.2 端口 80 后 0 毫秒失败: 无法连接到服务器 * 关闭连接 #0
内容来源: projectcalico/calico