#44315·server

[错误]: mimetypelist.js 哈希无效

作者: idressos创建于 2024年3月19日更新于 2026年9月17日
标签bug0. Needs triagefeature: install and updatepapercutfeature: occ28-feedback

⚠️ This issue respects the following points: ⚠️

Bug description

After running occ maintenance:mimetype:update-js, core integrity checks fail with the following error:

  • INVALID_HASH:
    • core/js/mimetypelist.js:
      • expected: 550ab566d30693bfa24ec4b15d9df87731ae8a3be8f79dabf94757e5b8b20eec6e4b678f17af1718297f2872f6b04519eeb024d1dff11947f29da431c7f11201
      • current: 24e6faa4a1361e51ff70027024f41c4b37fdb5f6f347ceb095450ddbde2d0a6b6dd1403be92a912d2889064a9736a9bed89d7dc62470035fc1299d4b977c5f46 The mimetypelist.js file has not been altered manually in any way.

Steps to reproduce

  1. In your server's command line, navigate to the Nextcloud root installation directory
  2. Execute php occ maintenance:mimetype:update-js
  3. Execute php occ integrity:check-core, or wait for cron task to do it on scheduled interval

Expected behavior

No integrity errors.

Installation method

Community Manual installation with Archive

Nextcloud Server version

master

Operating system

Debian/Ubuntu

PHP engine version

PHP 8.3

Web server

Apache (supported)

Database engine version

MariaDB

Is this bug present after an update or on a fresh install?

None

Are you using the Nextcloud Server Encryption module?

Encryption is Disabled

What user-backends are you using?

  • Default user-backend (database)
  • LDAP/ Active Directory
  • SSO - SAML
  • Other

Configuration report

bash
{
    "system": {
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "records.aviet.aero"
        ],
        "trusted_proxies": "***REMOVED SENSITIVE VALUE***",
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "MySQL",
        "version": "28.0.3.2",
        "overwrite.cli.url": "http:\/\/records.aviet.aero",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbport": "",
        "dbtableprefix": "oc_",
        "MySQL.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "installed": true,
        "maintenance": false,
        "memcache.local": "\\OC\\Memcache\\APCu",
        "memcache.locking": "\\OC\\Memcache\\Redis",
…

内容来源: nextcloud/server