#377·sshfs

添加 `-o no_acls`

作者: dmik创建于 2026年7月8日更新于 2026年7月8日

ACL 是一个域级元数据,通常它们是无法导入/导出的。目前,如果远程机器根本不支持 ACL (或者不以本地机器的方式支持 ACL,或者 ACL 策略不兼容),即使是简单的默认 `tar` 往返操作 (保留 ACL) 也会失败。此选项的想法是忽略与 ACL 相关的 FS 调用 (根本不将其发送到远程侧,并在本地报告成功)。这样,`tar` (以及许多其他类似情况) 就可以无缝工作,而无需为特定的 SSHFS 挂载点添加自定义工作绕过措施,例如 `tar x --no-acls` 等 (这通常是不可能的,因为 `tar` 是一个应用程序级工具,它认为它与本地 FS 相关,而 SSHFS 的整个理念就是让远程 FS 看起来像本地 FS,它对本地 FS 的语义一无所知,也不应该知道)。SSHFS 已经通过例如 `-o idmap` (用于映射 UID/GID) 将本地和远程机器之间的语义进行了映射。处理 ACL (扩展 ACL) 只是本书中的另一页。