基于 System.Text.Json 的支持,满足您所有的 JSON 需求。
什么是 json-everything? json-everything 的主要理念是确保 System.Text.Json 空间中对常见的 JSON 功能具有良好的支持。实现这一目标的第一步是检查是否存在其他支持给定功能的项目。如果有,那么此项工作可能不会在这里重复。稍后您会找到一些使用 JSON 完成一些很酷的事情的其他项目的列表。否则,它可以考虑添加到本项目中。 Playground 文档 博客 交互式学习 json-everything.net docs.json-everything.net blog.json-everything.net learn.json-everything.net 讨论 请求 使用了什么? 实际上有多个箱子。每个功能都被分解成了自己的库,因此您可以选择需要的库。所有库都构建为 .Net Standard 2.0 和 .Net 8、9 和 10。 JsonSchema.Net JSON 方案,草案 6 及更高版本 JsonSchema.Net.Generation 从 .Net 类型生成方案 JsonSchema.Net.Api 对 ASP.Net API 的 JSON 方案验证 JsonSchema.Net.Generation.DataAnnotations 对 System.ComponentModel.DataAnnotations 的方案生成支持 JsonSchema.Net.DataGeneration 随机实例数据生成(由 Bogus 提供) JsonSchema.Net.Data 访问实例和外部数据的词汇 JsonSchema.Net.ArrayExt 扩展数组验证的词汇 JsonSchema.Net.OpenApi OpenApi 3.1 词汇扩展(由 Graeae 使用) JsonPath.Net JSON 路径(RFC 9535) JsonPatch.Net JSON Patch(RFC 6902) JsonPointer.Net JSON 指针(RFC 6901)和相对 JSON 指针(规范) JsonLogic JsonLogic(网站) JsonE.Net JSON-e(网站) Json.More.Net 适用于一般用途的扩展,可能应该包含在 System.Text.Json[.Nodes] 中,但并未包含 Yaml2JsonNode YamlDotNet 中的 YAML 文档模型与 JsonNode 之间的转换(双向)。上述所有库都为其相关规范提供了完整的支持。JsonSchema.Net 的错误消息翻译可在以下语言包中使用: - 意大利语 it - 挪威语 nb-NO - 波兰语 pl-PL - 葡萄牙语 pt - 俄语 ru - 西班牙语 es - 瑞典语 sv-SE - 土耳其语 tr-TR 注意 每个语言包 i…
暂无开放 Issues,或尚未同步最近议题。