启动 cadvisor 以监控无根 Docker 容器时出错 (其他用户的 /sys/fs/cgroup/user.slice 权限被拒绝)
作者: srstsavage创建于 2025年9月15日更新于 2026年8月27日
运行 cadvisor (已测试 v0.53.0) 以监控无根 Docker 容器 (通过 systemd 用户范围服务管理的无根 Docker 守护进程) 时,如果除了管理无根 Docker 的用户以外还有其他用户登录到服务器,则 cadvisor 无法启动。这似乎是其他用户的 /sys/fs/cgroup/user.slice 目录的权限错误。
内容来源: google/cadvisor