#950·glance

在 startServer 失败时出现问题

作者: ddormer创建于 2026年2月7日更新于 2026年9月6日
标签bug report

说明

如[此处]所示,`启动服务器 ' 不在故障后退出(https://GitHub.com/glanceapp/glance/blob/main/Internal/glance/main.go#L142)。 我在系统化服务中运行Glance,无法得知服务器在没有退出代码的情况下启动失败.

是否存在依赖这种行为的现有代码? 或者在`启动服务器 ' 功能中安全地发出退出呼叫?

我想检测的失败的一个例子是,当端口已经使用时: “ 启动服务器失败: 请听 tcp 10. 0.0.5: 8581: 绑定: 无法指定请求的地址 ”

内容来源: glanceapp/glance