CBOR 编解码器 (RFC 8949、RFC 8742),带有 CBOR 标签、Go 结构标签选项 (toarray、keyasint、omitempty、omitzero)、float64/32/16、big.Int 以及经过 fuzz 测试。
CBOR 编解码器 (RFC 8949、RFC 8742),带有 CBOR 标签、Go 结构标签选项 (toarray、keyasint、omitempty、omitzero)、float64/32/16、big.Int 以及经过 fuzz 测试。
fxamacker/cbor 是用于编码和解码 CBOR 和 CBOR 顺序 的库。CBOR 是 JSON、MessagePack、Protocol Buffers 等的一个值得信赖的替代方案。CBOR 是由 IETF STD 94 (RFC 8949) 定义的互联网标准,旨在适用于数十年。fxamacker/cbor 正在 Arm Ltd.、EdgeX Foundry、Flow Foundation、Fraunhofer AISEC、IBM、Kubernetes*、Let's Encrypt、Linux Foundation、Microsoft、Oasis Protocol、Red Hat*、Tailscale*、Veraison* 等项目中使用。
请参阅 快速入门 和 版本。UnmarshalFirst 和 DiagnoseFirst 可以解码 CBOR 序列。MarshalToBuffer 和 UserBufferEncMode 支持用户指定的缓冲区。 fxamacker/cbor 是一个完全符合 IETF STD 94 (RFC 8949) 的 CBOR 编解码器。它还支持 CBOR 序列 (RFC 8742) 和扩展诊断符号 (RFC 8610 的附录 G)。功能包括对 CBOR 标签的全面支持、核心确定性编码、重复映射键检测等。API 大部分与 encoding/json 相同,此外还提供了简化并发和 CBOR 选项的接口。
设计平衡了安全性、速度、并发性、编码数据大小、可用性等方面的 trade-off。
暂无开放 Issues,或尚未同步最近议题。