#3038·falco

[跟踪] Falco 1.0.0 中的重大变更

作者: andreaterzolo创建于 2024年1月29日更新于 2026年9月13日
标签kind/documentationlifecycle/stale

此问题记录了 Falco 中将在 Falco 1.0.0 中移除的所有已淘汰的功能: * Falco 规则中的 append 已被淘汰,取而代之的是 override (请参阅 https://GitHub.com/falcosecurity/falco/pull/2992) * 如下语法已被淘汰,取而代之的是 override (请参阅 https://GitHub.com/falcosecurity/falco/pull/2992) ```yaml

  • rule: Write below etc enabled: false
yaml
- rule: Write below etc
  enabled: false
  override:
     enabled: replace
请注意,`enabled` 关键字仅在用作 override 时才被淘汰!因此,如下规则是完全合法的:  ```yaml
- rule: legit_rule
  desc: legit rule description
  condition: evt.type=open
  output: user=%user.name command=%proc.cmdline file=%fd.name
  priority: INFO
  enabled: false

内容来源: falcosecurity/falco