一个 Go 库,用于应用 RFC6902 补丁以及创建和应用 RFC7386 补丁
jsonpatch 是一款库,提供了对文档进行 RFC6902 JSON 补丁 的应用功能,以及计算和应用 RFC7396 JSON 合并补丁 的功能。
jsonpatch.SupportNegativeIndices。默认为 true,支持非标准的做法,允许负索引表示从数组末尾开始的索引。可以通过设置 jsonpatch.SupportNegativeIndices = false 来禁用此功能。jsonpatch.Apply 的一个替代方案是 jsonpatch.ApplyWithOptions,其行为由类型为 *jsonpatch.ApplyOptions 的 options 参数控制。jsonpatch.ApplyOptions 结构包含上述配置选项,并添加了两个新选项:AllowMissingPathOnRemove 和 EnsurePathExistsOnAdd。当 AllowMissingPathOnRemove 设置为 true 时,jsonpatch.ApplyWithOptions 将忽略 remove 操作,其中 path 指向 JSON 文档中不存在的位置。AllowMissingPathOnRemove 默认为 false,这将导致 jsonpatch.ApplyWithOptions 在删除时遇到缺失的 path 时返回错误。
当 EnsurePathExistsOnAdd 设置为 true 时, jsonpatch.ApplyWithOptions 会确保 add 操作生成目标对象中缺少的所有 path 元素。
暂无开放 Issues,或尚未同步最近议题。