[部署问题] 无法启动 caprover
作者: skliarie创建于 2026年2月17日更新于 2026年6月18日
标签deployment-issue
我试图在没有互联网直接接入的情况下在环境中奔跑。 我已经使用“ MAIN NODE IP ADDES=127. 0.0.1 ” env变量
我们使用JFrog Artifactory作为Docker图像下载的"代理". 因此,我们想要下载的任何Docker图像都必须有特殊的URL("前缀"). 例如,我用这个来下载 Caprover 图像:
内部.域名/Docker-虚拟/封顶/封顶
当相机启动时,它会尝试直接下载nginx,这是不可能的. 此错误失败 :
拉动:正辛醇/水分配系数: 1.27.2
安装失败 。
错误:(HTTP代码为500)服务器错误 - 未能解决引用"Docker.io/library/nginx:1.27.2" 错误:未实现请求:头"https://registry-1.ZZZM5Z.io/v2/library/nginx/manifests/1.27.2" :拨打tcp:查询注册号-1.Docker.io on 127.0.0.53:53:读作udp 127.0.0.1:58635->127.0.0.53:i/o超时我怎么能让它知道 nginx 图像的内部 URL ?
内容来源: caprover/caprover