SDL/声明式 (PostgreSQL): SDL 解析器拒绝创建扩展,但差异需要创建扩展,因此扩展所拥有的函数会被删除
作者: jowinjestine创建于 2026年8月4日更新于 2026年8月24日
SDL/declarative (PostgreSQL): CREATE EXTENSION is rejected by the SDL parser but required by the SDL differ, so extension-owned functions get DROP FUNCTION
概要
在对 PostgreSQL 的 declarative (SDL) 模式下,安装了扩展的数据库无法进行管理。该功能的两个部分相互矛盾:
Export Schema发出CREATE EXTENSION,但 SDL 解析器拒绝了它。 导出的模式不符合双向清理 — 将 Bytebase 自身的导出作为 SDL 文件输入并检查失败。
内容来源: bytebase/bytebase