#3842·Checkmate

在 Linux 内核 6.19+ / 7.0.x 上无法启动 MongoDB (SERVER-121912) - 应用程序返回 502, DB 连接被拒绝

作者: AdimoUK创建于 2026年8月17日更新于 2026年9月11日

升级主机到较新的 Linux 内核(Proxmox VE 9,内核 `7.0.14-12-pve` - Proxmox 8 在 2026 年 8 月 31 日停止支持,而当前版本 Proxmox 9.2 则默认配备了 trixie 内核 7.0.14)后,Checkmate 开始返回 502。Checkmate 服务器启动了,但无法连接到 MongoDB,日志中重复出现 `connect ECONNREFUSED 127.0.0.1:27017`。根本原因不是 Checkmate 本身,而是 MongoDB 存在已知问题:MongoDB 8.0+ 由于与 Linux 内核 6.19 和更高版本存在不兼容性,拒绝启动,在启动时退出,输出如下:

内容来源: bluewave-labs/Checkmate