[Bug]: Cannot connect SMTP Provider
Author: mkalinski93Created Aug 1, 2025Updated Sep 18, 2026
LabelsTo-be-closed
Preflight Checklist
- I could not find a solution in the documentation, the existing issues or discussions
- I have joined the ZITADEL chat
Environment
Self-hosted
Version
v4.0.0-rc.2
Database
PostgreSQL
Database Version
16.3
Describe the problem caused by this bug
We have a problem with our Mailjet smtp integration.
We have a Kubernetes cluster with nginx ingress installed. If I have a local docker container running a Zitadel instance, I have no problem with Mailjet. But as soon as the Zitadel instance is installed via helm on our cluster, then we will receive this error when we test the smtp provider.
RpcError(UNKNOWN): Http response at 400 or 500 level, http status code: 0To reproduce
Screenshots
No response
Expected behavior
No response
Operating System
No response
Relevant Configuration
No response
Additional Context
No response
Source: zitadel/zitadel