log message format
It seems that error messages from youki do not appear in docker logs. Is this a known issue?
I built youki and set it up for docker. Due to TIME_NAMESPACE issue, the command should fail. Actually, it fails but no meaningful messages in docker log (journalctl -u docker).
In fact, containerd anyhow passes "--log" to youki as it does for other runtimes, and I expect that this option should enable message logging. (I know there is another option, "--systemd-log", which has the same effect instead.) The reason is that the format of messages generated by youki (tracing-subscriber) is not compatible with the one in runc. Therefore, any messages are filtered out.
Is this an intended behavior for development releases, or do I miss anything? FYI, I created a small patch that would convert messages to runc-compatible format, (I know log format is not part of OCI specification) and it works without "--systemd-log".
Source: youki-dev/youki