Nebula crashes after running `RETURN ()--() AS p;`
Author: zihaozeng0021Created Dec 25, 2025Updated Dec 25, 2025
Labelstype/bugseverity/noneaffects/none
Configuration
Nebula Version: 2025.10.28-nightly
Operating System: WSL2 – Ubuntu 24.04.1 LTS
Installation Method: Docker
Steps to reproduce
- Start Nebula via Docker
docker exec -it nebula-docker-compose-console-1 sh- Connect with
nebula-console:
nebula-console -u root -p nebula -addr graphd -port 9669- Run the following query:
Create a test space
CREATE SPACE IF NOT EXISTS test(partition_num=1, replica_factor=1, vid_type=FIXED_STRING(8));Select the space
use testRun the buggy query:
RETURN ()--() AS pExpected behaviour
The query should either:
- return an empty result set, or
- return a normal query error (syntax/semantic), without dropping the connection.
Actual behaviour
After running RETURN ()--() AS p, nebula-console starts a reconnect loop and fails with connection refused to graphd:9669:
(root@nebula) [(none)]> use test
Execution succeeded (time spent 1.171ms/1.487435ms)
Thu, 25 Dec 2025 05:59:40 UTC
(root@nebula) [test]> RETURN ()--() AS p;
2025/12/25 06:00:02 Loop error, failed to reconnect, failed to open transport, error: dial tcp 172.19.0.10:9669: connect: connection refused
/ #Source: vesoft-inc/nebula