#2121·tigervnc

Can't connect to a 4k server: TightDecoder: Too large rectangle (3840 pixels)

Author: marmarekCreated Jun 15, 2026Updated Sep 15, 2026
Labelsnotourbug

Describe the bug

TigerVNC 1.16.2 fails to connect to a server with 4k resolution. The error is:

TigerVNC v1.16.2
Built on: 2026-04-16 00:00
Copyright (C) 1999-2026 TigerVNC team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.

Mon Jun 15 00:26:25 2026
 DecodeManager: Detected 8 CPU core(s)
 DecodeManager: Creating 4 decoder thread(s)
 CConn:       Connected to host hal9017.testnet port 5900
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 CConnection: Choosing security type VeNCrypt(19)
 CVeNCrypt:   Choosing security type None (1)
 DesktopWindow: Adjusting window size to avoid accidental full-screen request
 CConnection: Enabling continuous updates
 CConn:       TightDecoder: Too large rectangle (3840 pixels)
 DecodeManager:   Total: 0 rects, 0 pixels
 DecodeManager:          0 B (1:-nan ratio)

It worked just fine in TigerVNC 1.15.0:

TigerVNC viewer v1.15.0
Built on: 2025-06-23 00:00
Copyright (C) 1999-2025 TigerVNC team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.

Mon Jun 15 00:27:11 2026
 DecodeManager: Detected 8 CPU core(s)
 DecodeManager: Creating 4 decoder thread(s)
 CConn:       Connected to host hal9017.testnet port 5900
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 CConnection: Choosing security type VeNCrypt(19)
 CVeNCrypt:   Choosing security type None (1)
 DesktopWindow: Adjusting window size to avoid accidental full-screen request
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
 CConnection: Enabling continuous updates

Mon Jun 15 00:27:15 2026
 DecodeManager:     Tight: 4 rects, 33.1776 Mpixels
 DecodeManager:            1.25478 MiB (1:100.865 ratio)
 DecodeManager:   Total: 4 rects, 33.1776 Mpixels
 DecodeManager:          1.25478 MiB (1:100.865 ratio)

To Reproduce Steps to reproduce the behavior:

  1. Have a server with 4k resolution
  2. Launch vncviewer SERVER_ADDRESS
  3. See error

Expected behavior

It should connect normally.

Client (please complete the following information):

  • OS: Fedora Linux 43
  • VNC client: TigerVNC
  • VNC client version: 1.16.2
  • Client downloaded from: Fedora package

Server (please complete the following information):

  • OS: Linux
  • VNC server: PiKVM
  • VNC server version: KVMD-VNC/4.100
  • Server downloaded from: built from source
  • Server was started using: systemctl start kvmd-vnc

Additional context

I strongly suspect it's about this commit: https://github.com/TigerVNC/tigervnc/commit/f3954bee34dbb3aabe8d1d42a9965308ef42724b