#777·tile38

Callback Requests to Kafka 4.0 Fail with Error

Author: ifiokCreated Aug 27, 2025Updated Aug 27, 2025

Describe the bug Due to the forceful deprecation of Kafka APIs in 4.0, the callback requests used by the IBM Sarama package for Kafka fails. Sarama has been updated to handle this error in their latest release (1.46.0) https://github.com/IBM/sarama/releases/tag/v1.46.0

To Reproduce Steps to reproduce the behavior: Set the callback URL to a Kafka 4.0 cluster.

Expected behavior Expected to publish to the Kafka broker successfully .

Logs If applicable, provide logs, panics, system messages to help explain your problem.

2025-08-27T06:26:20.850+01:00[2025-08-27 05:26:20,850] ERROR Exception while processing request from 10.0.32.25:9093-10.0.51.11:54970-3-25282 (kafka.network.Processor)
2025-08-27T06:26:20.850+01:00org.apache.kafka.common.errors.UnsupportedVersionException: Received request for api with key 0 (Produce) and unsupported version 2

Operating System (please complete the following information):

  • OS: [Linux]
  • CPU: [amd64l]
  • Version: [e.g. 1.36.0]
  • Container: [Docker]

Additional context Add any other context about the problem here.