#7270·thanos

Support for encryption in transit for Memcached

Author: DonovanSoftlyCreated Apr 9, 2024Updated Sep 3, 2026

Is your proposal related to a problem?

We have activated the encryption in transit on our Amazon ElastiCache for Memcached. Afterwards, Thanos failed to connect to memcached like the error below.

ts=2024-04-09T02:47:04.90578891Z caller=memcached.go:250 level=error msg="failed to put to memcached" name= err="read tcp 10.170.59.248:58922->10.170.49.42:11211: read: connection reset by peer"

Describe the solution you'd like

Support for encryption in transit for Memcached