disable dns cache flush
Author: ileGITimoCreated May 30, 2026Updated May 30, 2026
Is there a way to disable sshuttle's attempt to flush the DNS cache?
Maybe my systemd or NetworkManager is misconfigured. I run named on the machine where I use sshutle, have systemd-resolved disabled/masked,NM has dns=none, and manually manage adding remote hosts to /etc/hosts. When I start sshuttle I always get these warnings:
Failed to flush caches: Could not activate remote peer 'org.freedesktop.resolve1': activation request failed: unknown unit fw: Received non-zero return code 1 when flushing DNS resolver cache.
Everything works, it is just slightly annoying.
Source: sshuttle/sshuttle