#1227·nebula

BUG: "Listener is IPv4, but writing to IPv6 remote" error is usually unhelpful

Author: johnmaguireCreated Sep 23, 2024Updated Jul 2, 2026
LabelsNeedsDecision

What version of nebula are you using? (nebula -version)

1.9.4

What operating system are you using?

Linux

Describe the Bug

If a host has IPv6 disabled in the kernel, or listen.host set to 0.0.0.0, and the Lighthouse returns an IPv6 address during the handshake process, this error will occur. This confuses a lot of users into thinking it's the cause of ~(whatever issues they happen to be having). Usually, it just means the host will find a tunnel over IPv4 instead.

Maybe we can make this message warning-level, debug-level, less frequent, more informative, or occur in fewer configurations?

@wadey suggested defaulting local_allow_list and remote_allow_list to to exclude IPv6 when we see listen.host is set to 0.0.0.0 or IPv6 is disabled in the kernel. (This can be done manually as a workaround today.)

Logs from affected hosts

n/a

Config files from affected hosts

n/a