[collect] LKE - Containerd - Log from file - Not pick up by Signoz
Bug description
we have signoz install on Kubernetes cluster, our app pod running in default namespace have log files at /app/resources/logs/access-${HOSTNAME}.log /app/resources/logs/${HOSTNAME}.log
We tried to add log file path into ConfigMap otel-agent-config.yaml but dosen't seem to be working.... any help appreciated.. Thanks receivers: filelog/k8s: exclude: - /var/log/pods/kube-system_*//.log - /var/log/pods/_hotrod//.log - /var/log/pods/locust*//.log include: - /var/log/pods///.log - /var/log/pods////.log - /app/resources/logs/*.log - /var/log/pods/default//app/resources/logs/.log - /var/log/pods//////*.log
Expected behavior
Logs from File should be able to pick up by Sigznoz as per - https://signoz.io/docs/userguide/collect_logs_from_file/
Version information
- Signoz version: v0.38.2
- Browser version: Chrome / all other tried
- Your OS and version: LKE - Linode Kubernetes Engine / CRI : containerd
- Your CPU Architecture(ARM/Intel):
Additional context
we on Linode Kubernetes Engine - LKE - current Kubernetes version: v1.28.6 Kubernetes CRI Version: 0.1.0 RuntimeName: containerd RuntimeVersion: 1.6.25 RuntimeApiVersion: v1 getting ERROR when try to exec into otel-agent pod ➜ ~ kubectl -n platform exec -it prod-signoz-k8s-infra-otel-agent-kwj7z -- /bin/bash Warning: Use tokens from the TokenRequest API or manually created secret-based tokens instead of auto-generated secret-based tokens. error: Internal error occurred: error executing command in container: failed to exec in container: failed to start exec "07a610eeaa9278fed88dcf722227c0e32f94dc1efff7103f398f43f7fdd7fe6d": OCI runtime exec failed: exec failed: unable to start container process: exec: "/bin/bash": stat /bin/bash: no such file or directory: unknown
Thank you for your bug report – we love squashing them!
Source: SigNoz/signoz