#645·shuttle

Unrecoverable errors while running locally do not return any specific error in terminal

Author: joshua-mo-143Created Feb 22, 2023Updated Mar 12, 2025
LabelsS-Investigation

Discord thread ref: https://discord.com/channels/803236282088161321/1077698025155215360

If a web service panics while running locally, it will simply return this:

Error: Custom error:

With proper error handling generally this should not happen, but in cases where it does due to user error (for example: could not unwrap a value critical to the webservice running because it couldn't be found and therefore it panics), the local run will simply panic and then return the above. This can be solved by attempting to deploy, then checking the deploy logs and seeing exactly where the web service panicked on, but generally this isn't ideal for reasons related to having to potentially deploy before a service is ready for production (amongst others).

I'm not really sure how to fix this issue since local logging appears to be streamed through a channel - some guidance would be appreciated here. Some minor documentation changes will be made to make sure it's explicitly clear that the Secrets.toml file should be at the Cargo.toml level and hopefully prevent confusion.