(REDIS) Worker stop consuming messages without any warnings or errors
Author: pjmullerCreated Mar 22, 2021Updated Jan 30, 2026
Hi,
My REDIS worker just stops consuming message from one moment to the other and doesn't show any warnings or errors in the logs. Right before it happens I see the connections peak to 140 (where normally it's around 60). My max connections are 512 so I'm not cutoff on REDIS server level, it's within machinery that he stops listening.
My main questions are
- does this sound familiar? What could be the cause for machinery to open a lot more redis connections?
- what are the typical reasons for a worker to not consume messages anymore? Can it reconnect when it notices it's connection got faulty?
PS: very strange that the connections stay open even though nothing is being consumed anymore.
Source: RichardKnop/machinery