Failed to remove a node from the cluster
I'm trying to delete server from cluster. To do this, I stop the database, then delete the rethinkdb data and start DB with another config file, where there is no join and canonical-address parameters.
On the server where the database is being cleaned up, I receive a message:
warn: Remote node refused to connect with us, peer: 192.168.138.168:51556, reason: "unexpected server id (actual: abd2571e-699e-4dbd-9f8e-5e7f9641def1, expected: dc708f19-f38b-4247-9d27-743f28930078)"
On another server I receive a message:
warn: Connection attempt from 192.168.138.165:29015 failed, reason: unexpected server id (actual: abd2571e-699e-4dbd-9f8e-5e7f9641def1, expected: dc708f19-f38b-4247-9d27-743f28930078)
How to properly remove a node from the cluster?
Source: rethinkdb/rethinkdb