#13848·PrusaSlicer

Linux flatpak uses different DNS config than host and doesn't report effectively when broken

Author: enygrenCreated Dec 26, 2024Updated Sep 19, 2026
Labelslegacy-issue

Description of the bug

The Linux flatpak packaging of PrusaSlicer 2.9.0 uses an alternate /etc/nsswitch.conf from that of the host. This forces the use of systemd-resolved if it is running, even if its usage isn't configured on the host via /etc/nsswitch.conf. The result is that if systemd-resolved is running but misconfigured on the host but worked around via /etc/nsswitch.conf, DNS will break within the flatpak container causing anything needing network access to not work effectively.

Note that while this is not strictly a bug in the container packaging, it took me hours of debugging to trace this down since DNS was working fine on the host (due to nsswitch.conf bypassing systemd-resolved and using resolv.conf) but breaking within the container (due to using its own nsswitch.conf).

Project file & How to reproduce

If systemd-resolved is in a bad state, DNS in the flatpak container won't work. The user won't get any indication of this other than broken networking.

Some ways to test:

flatpak run --command=curl com.prusa3d.PrusaSlicer -v 'https://www.prusa3d.com/'

(should work, but will return a DNS error if broken)

To see if DNS is working on the host with systemd-resolved, if this fails on the host then this needs to get fixed by the user before the container will work:

resolvectl query example.com

Checklist of files included above

  • Project file
  • Screenshot

Version of PrusaSlicer

2.9.0

Operating system

Ubuntu 22.04

Printer model

mk3.5