#1392·postgresml

Issues with Docker container on port 5432

Author: ozzytekconsultCreated Mar 29, 2024Updated Dec 12, 2025
Labelsquestion

Hi,

I'm having an issue running PostgresML in a Docker container, on an Ubuntu 22.04 server. Like this

bash
docker run -d --name postgresml --restart always  \
    -v postgresml_data:/var/lib/postgresql \
    -p 5433:5432 \
    -p 8089:8000 \
    ghcr.io/postgresml/postgresml:2.8.2 

The Ubuntu 22.04 server is running Postgres 16 locally on port 5432 (not on a Docker container). Hence my exposing the containerized Postgresml on port 5433. So I don't see any reasons why I should be getting the errors below when I try to run the container

Starting PostgresML

  • Starting PostgreSQL 15 database server ...done. Starting dashboard Starting PostgresML
  • Starting PostgreSQL 15 database server
  • Removed stale pid file. Error: /usr/lib/postgresql/15/bin/pg_ctl /usr/lib/postgresql/15/bin/pg_ctl start -D /var/lib/postgresql/15/main -l /var/log/postgresql/postgresql-15-main.log -s -o -c config_file="/etc/postgresql/15/main/postgresql.conf" exited with status 1: 2024-03-29 16:16:22.637 UTC [21] LOG: starting PostgreSQL 15.6 (Ubuntu 15.6-1.pgdg22.04+1) on x86_64-pc-linux-gnu, compiled by gcc (Ubuntu 11.4.0-1ubuntu1~22.04) 11.4.0, 64-bit 2024-03-29 16:16:22.637 UTC [21] LOG: listening on IPv4 address "0.0.0.0", port 5432 2024-03-29 16:16:22.643 UTC [21] FATAL: lock file "/var/run/postgresql/.s.PGSQL.5432.lock" already exists 2024-03-29 16:16:22.643 UTC [21] HINT: Is another postmaster (PID 22) using socket file "/var/run/postgresql/.s.PGSQL.5432"? 2024-03-29 16:16:22.648 UTC [21] LOG: database system is shut down pg_ctl: could not start server Examine the log output. ...fail! Starting dashboard Starting PostgresML
  • Starting PostgreSQL 15 database server ...done. Starting dashboard Starting PostgresML
  • Starting PostgreSQL 15 database server

Any idea why this is happening and how to fix it?

Thanks