[Bug]: "CSV using LOAD DATA" import with charset selection results in "This plugin does not support compressed imports!"
Author: cillianderoisteCreated Jul 28, 2026Updated Sep 9, 2026
LabelsBug
Describe the bug
If you select any charset other than utf8 for importing "CSV using LOAD DATA" an error message is shown: "This plugin does not support compressed imports!"
If I understand correctly, this is due to the condition here: https://github.com/phpmyadmin/phpmyadmin/blob/RELEASE_5_2_3/libraries/classes/Plugins/Import/ImportLdi.php#L103 since $charset_conversion is not False, the error is thrown.
How to Reproduce
- Go to database table
- Click "Import"
- Select CSV file
- Select any charset, other than utf8
- Under Format, select "CSV using LOAD DATA"
- Click "Import"
- An error is displayed: "This plugin does not support compressed imports!"
Expected behavior
I expected the data to be imported with the correct character set.
I was able to add $sql .= ' CHARACTER SET latin1 '; to the code to force it to use latin1 and it worked.
Screenshots
No response
Operating System
Linux
Web Server
Nginx
Database Server
MariaDB
Database version
11.8.6-MariaDB-5ubuntu0.1 from Ubuntu
PHP version
8.5.4
phpMyAdmin version
5.2.3deb1
browser
Firefox v152.0.4
Additional context
No response
Source: phpmyadmin/phpmyadmin