Reload of ca_file periodically/on file change

Author: jvmdcCreated Sep 10, 2024Updated Sep 20, 2026
LabelsStale

Is your feature request related to a problem? Please describe. We are running in Kubernetes and mounting a config map with our CAs into the OpenTelemetry Collector that is then used by the ca_file config option.

This config map will change whenever the cluster rotates its CA files, but since updates are not propagated into the OpenTelemetry Collector, at some point the collector (acting as a client) will fail to validate the server'scertificate, thus failing to propagate telemetry.

Describe the solution you'd like The ability to enable file reload for the ca_file option, similarly to client_ca_file_reload (file-system watching for client CA validation) or reload_interval (time-based for the collector's own cert and key when acting as a server)

Describe alternatives you've considered Our current approach is to restart the OpenTelemetry Collector to pick up the changes

Source: open-telemetry/opentelemetry-collector