Web resources transferred with the wrong MIME type
Checklist
- Have you pulled and found the error with
jc21/nginx-proxy-manager:latestdocker image?- Yes
- Are you sure you're not using someone else's docker image?
- Yes, this is the docker compose
- Have you searched for similar issues (both open and closed)?
- Yes, found this similar one: #284
Describe the bug When accessing a proxied server, the browser blocks some resources because of a wrong MIME type
Nginx Proxy Manager Version v2.9.19
To Reproduce Steps to reproduce the behavior: Perhaps it's an issue with custom locations:
- Access server like hostip/service
- inspect
- open console There may be errors loading some resources
Expected behavior
Screenshots Console error
nextcloud, like this because it doesn't load css homeassistant, stuck here because it doesn't load js
setup screenshots: NPM, proxy host and custom locations
Operating System Raspberry pi (192.168.1.5) with raspberry OS and all the services are on docker, on the same bridge network: NPM (172.19.0.4), portainer (172.19.0.3), nextcloud (172.19.0.5) and homeassistant (172.19.0.2) of which NPM and portainer properly load, while nextcloud and homeassistant fail to load some resources
Additional context Have tried with firefox and chrome. Accessing directly works fine. NPM logs are clear, there is the browser request and the file is sent
Logs for a connection to NPM and then portainer proxy-host-6_access.log proxy-host-6_error.log
Logs for connections to nextcloud and then homeassistant proxy-host-6_access.log proxy-host-6_error.log
Source: NginxProxyManager/nginx-proxy-manager