#1806·NetAlertX

Proxmox install script fails when it attempts to create /app/api directory as Git has already created it as a symlink to /tmp/api

Author: leeatkinsonCreated Sep 22, 2026Updated Sep 22, 2026
Labelsbug 🐛help wanted 🆘Contributors 🙏

What installation are you running?

Production (netalertx)

Is there an existing issue for this?

The issue occurs in the following browsers. Select at least 2.

  • Firefox
  • Chrome
  • Edge
  • Safari (unsupported) - PRs welcome
  • N/A - This is an issue with the backend

Current Behavior

When running: wget https://raw.githubusercontent.com/netalertx/NetAlertX/refs/heads/main/install/proxmox/proxmox-install-netalertx.sh -O proxmox-install-netalertx.sh && chmod +x proxmox-install-netalertx.sh && ./proxmox-install-netalertx.sh

...in Proxmox Debian LXC container, the script will fail with: mkdir: cannot create directory ‘/app/api’: File exists

This is because /app/api has already been created as a symlink to /tmp/api by Git.

Expected Behavior

Installation on Proxmox LXC container to suceed.

Steps To Reproduce

  1. Create Debian LXC container (I used https://community-scripts.org/scripts/debian)
  2. Run wget https://raw.githubusercontent.com/netalertx/NetAlertX/refs/heads/main/install/proxmox/proxmox-install-netalertx.sh -O proxmox-install-netalertx.sh && chmod +x proxmox-install-netalertx.sh && ./proxmox-install-netalertx.sh
  3. Monitor output

Relevant app.conf settings

python
N/A

docker-compose.yml

yaml
N/A

Debug or Trace enabled

  • I have read and followed the steps in the wiki link above and provided the required debug logs and the log section covers the time when the issue occurs.

Relevant app.log section

N/A

Docker Logs

N/A