Resolver stops working with Docker 26.1.3
Environment & Version
- Docker: 26.1.3, build b72abbb
- Docker Compose: v2.27.0
- Mailu: 2.0.43
- Platform: Ubuntu 22.04.4
Description
The resolver container stops working after upgrading Docker. (It worked fine.) The symptom is similar to this issue: https://github.com/Mailu/Mailu/issues/2868 Though docker compose exec front ping 1.1.1.1 worked for me (but not docker compose exec front ping google.com).
I temporarily fixed the issue by changing DNS from 172.31.203.254 to 1.1.1.1 for all containers in docker-compose.yml, but I wish to use mailu's resolver again.
Replication Steps
Download a setup from setup.mailu.io and run docker compose up -d.
Observed behaviour
The admin container keeps reporting DNS resolution error, eventually transitioning from "starting" to "unhealthy" status. As a result, the web UI doesn't work.
Expected behaviour
The admin container should succeed in resolving DNS from the resolver container without errors.
Logs
$ docker compose logs admin
[...]
admin-1 | CRITICAL:root:Your DNS resolver at 127.0.0.11 is not working (All nameservers failed to answer the query example.org. IN A: Server 1
27.0.0.11 UDP port 53 answered SERVFAIL). Please see https://mailu.io/master/faq.html#the-admin-container-won-t-start-and-its-log-says-critical
-your-dns-resolver-isn-t-doing-dnssec-validation
[...repeated...]$ docker exec -it resolver nslookup example.org localhost
;; communications error to ::1#53: connection refused
;; communications error to ::1#53: connection refused
;; communications error to ::1#53: connection refused
Server: localhost
Address: 127.0.0.1#53
** server can't find example.org: SERVFAILSource: Mailu/Mailu