Baike.dev
All toolsOnline toolsAI codingTrendingOpen sourceNewsSubmit
Log in
< Back to tools
W

web-check

> 安全
Open source

🕵️‍♂️ All-in-one OSINT tool for analysing any website

34.3K stars0 likes4 views
WebsiteGitHub

About

🕵️‍♂️ All-in-one OSINT tool for analysing any website

Web-Check


Comprehensive, on-demand open source intelligence for any website
🌐 web-check.xyz

---

Kindly supported by:


NinjaPear

API to get a full B2B profiles from any URL

Terminal Trove

The $HOME of all things in the terminal

Warp

Built for coding with multiple AI agents
#### Contents - **[About](#about)** - [Screenshot](#screenshot) - [Live Demo](#live-demo) - [Mirror](#mirror) - [Features](#features) - **[Usage](#usage)** - [Deployment](#deployment) - [Option#1: Netlify](#deploying---option-1-netlify) - [Option#2: Vercel](#deploying---option-2-vercel) - [Option#3: Docker](#deploying---option-3-docker) - [Option#4: Render](#deploying---option-4-render) - [Option#5: Source](#deploying---option-5-from-source) - [Configuration Options](#configuring) - [Developer Setup](#developing) - **[Community](#community)** - [Contributing](#contributing) - [Bugs](#reporting-bugs) - [Support](#supporting) - **[License](#license)** --- ## About Get an insight into the inner-workings of a given website: uncover potential attack vectors, analyse server architecture, view security configurations, and learn what technologies a site is using. Currently the dashboard will show: IP info, SSL chain, DNS records, cookies, headers, domain info, search crawl rules, page map, server location, redirect ledger, open ports, traceroute, DNS security extensions, site performance, trackers, associated hostnames, carbon footprint. Stay tuned, as I'll add more soon! The aim is to help you easily understand, optimize and secure your website. ### Screenshot Expand Screenshot ### Live Demo A hosted version can be accessed at: **[web-check.as93.net](https://web-check.as93.net)** ### Mirror The source for this repo is mirrored to CodeBerg, available at: **[codeberg.org/alicia/web-check](https://codeberg.org/alicia/web-check)** ### Status Build & Deploys: [](https://app.netlify.com/sites/web-check/deploys)
Repo Management & Miscellaneous: [](https://github.com/Lissy93/web-check/actions/workflows/mirror.yml) ### Features Click to expand / collapse section **Note** _this list needs updating, many more jobs have been added since..._ The following section outlines the core features, and briefly explains why this data might be useful for you to know, as well as linking to further resources for learning more. IP Info ###### Description An IP address (Internet Protocol address) is a numerical label assigned to each device connected to a network / the internet. The IP associated with a given domain can be found by querying the Domain Name System (DNS) for the domain's A (address) record. ###### Use Cases Finding the IP of a given server is the first step to conducting further investigations, as it allows us to probe the server for additional info. Including creating a detailed map of a target's network infrastructure, pinpointing the physical location of a server, identifying the hosting service, and even discovering other domains that are hosted on the same IP address. ###### Useful Links - [Understanding IP Addresses](https://www.digitalocean.com/community/tutorials/understanding-ip-addresses-subnets-and-cidr-notation-for-networking) - [IP Addresses - Wiki](https://en.wikipedia.org/wiki/IP_address) - [RFC-791 Internet Protocol](https://tools.ietf.org/html/rfc791) - [whatismyipaddress.com](https://whatismyipaddress.com/) SSL Chain ###### Description SSL certificates are digital certificates that authenticate the identity of a website or server, enable secure encrypted communication (HTTPS), and establish trust between clients and servers. A valid SSL certificate is required for a website to be able to use the HTTPS protocol, and encrypt user + site data in transit. SSL certificates are issued by Certificate Authorities (CAs), which are trusted third parties that verify the identity and legitimacy of the certificate holder. ###### Use Cases SSL certificates not only provide the assurance that data transmission to and from the website is secure, but they also provide valuable OSINT data. Information from an SSL certificate can include the issuing authority, the domain name, its validity period, and sometimes even organization details. This can be useful for verifying the authenticity of a website, understanding its security setup, or even for discovering associated subdomains or other services. ###### Useful Links - [TLS - Wiki](https://en.wikipedia.org/wiki/Transport_Layer_Security) - [What is SSL (via Cloudflare learning)](https://www.cloudflare.com/learning/ssl/what-is-ssl/) - [RFC-8446 - TLS](https://tools.ietf.org/html/rfc8446) - [SSL Checker](https://www.sslshopper.com/ssl-checker.html) DNS Records ###### Description This task involves looking up the DNS records associated with a specific domain. DNS is a system that translates human-readable domain names into IP addresses that computers use to communicate. Various types of DNS records exist, including A (address), MX (mail exchange), NS (name server), CNAME (canonical name), and TXT (text), among others. ###### Use Cases Extracting DNS records can provide a wealth of information in an OSINT investigation. For example, A and AAAA records can disclose IP addresses associated with a domain, potentially revealing the location of servers. MX records can give clues about a domain's email provider. TXT records are often used for various administrative purposes and can sometimes inadvertently leak internal information. Understanding a domain's DNS setup can also be useful in understanding how its online infrastructure is built and managed. ###### Useful Links - [What are DNS records? (via Cloudflare learning)](https://www.cloudflare.com/learning/dns/dns-records/) - [DNS Record Types](https://en.wikipedia.org/wiki/List_of_DNS_record_types) - [RFC-1035 - DNS](https://tools.ietf.org/html/rfc1035) - [DNS Lookup (via MxToolbox)](https://mxtoolbox.com/DNSLookup.aspx) Cookies ###### Description The Cookies task involves examining the HTTP cookies set by the target website. Cookies are small pieces of data stored on the user's computer by the web browser while browsing a website. They hold a modest amount of data specific to a particular client and website, such as site preferences, the state of the user's session, or tracking information. ###### Use Cases Cookies can disclose information about how the website tracks and interacts with its users. For instance, session cookies can reveal how user sessions are managed, and tracking cookies can hint at what kind of tracking or analytics frameworks are being used. Additionally, examining cookie policies and practices can offer insights into the site's security settings and compliance with privacy regulations. ###### Useful Links - [HTTP Cookie Docs (Mozilla)](https://developer.mozilla.org/en-US/docs/Web/HTTP/Cookies) - [What are Cookies (via Cloudflare Learning)](https://www.cloudflare.com/learning/privacy/what-are-cookies/) - [Testing for Cookie Attributes (OWASP)](https://owasp.org/www-project-web-security-testing-guide/v42/4-Web_Application_Security_Testing/06-Session_Management_Testing/02-Testing_for_Cookies_Attributes) - [RFC-6265 - Cookies](https://tools.ietf.org/html/rfc6265) Crawl Rules ###### Description Robots.txt is a file found (usually) at the root of a domain, and is used to implement the Robots Exclusion Protocol (REP) to indicate which pages should be ignored by which crawlers and bots. It's good practice to avoid search engine crawlers from over-loading your site, but should not be used to keep pages out of search results (use the noindex meta tag or header instead). ###### Use Cases It's often useful to check the robots.txt file during an investigation, as it can sometimes disclose the directories and pages that the site owner doesn't want to be indexed, potentially because they contain sensitive information, or reveal the existence of otherwise hidden or unlinked directories. Additionally, understanding crawl rules may offer insights into a website's SEO strategies. ###### Useful Links - [Google Search Docs - Robots.txt](https://developers.google.com/search/docs/advanced/robots/intro) - [Learn about robots.txt (via Moz.com)](https://moz.com/learn/seo/robotstxt) - [RFC-9309 - Robots Exclusion Protocol](https://datatracker.ietf.org/doc/rfc9309/) - [Robots.txt - wiki](https://en.wikipedia.org/wiki/Robots_exclusion_standard) Headers ###### Description The Headers task involves extracting and interpreting the HTTP headers sent by the target website during the request-response cycle. HTTP headers are key-value pairs sent at the start of an HTTP response, or before the actual data. Headers contain important directives for how to handle the data being transferred, including cache policies, content types, encoding, server information, security policies, and more. ###### Use Cases Analyzing HTTP headers can provide significant insights in an OSINT investigation. Headers can reveal specific server configurations, chosen technologies, caching directives, and various security settings. This information can help to determine a website's underlying technology stack, server-side security measures, potential vulnerabilities, and general operational practices. ###### Useful Links - [HTTP Headers - Docs](https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers) - [RFC-7231 Section 7 - Headers](https://datatracker.ietf.org/doc/html/rfc7231#section-7) - [List of header response fields](https://en.wikipedia.org/wiki/List_of_HTTP_header_fields) - [OWASP Secure Headers Project](https://owasp.org/www-project-secure-headers/) Quality Metrics ###### Description Using Lighthouse, the Quality Metrics task measures the performance, accessibility, best practices, and SEO of the target website. This returns a simple checklist of 100 core metrics, along with a score for each category, to gauge the overall quality of a given site. ###### Use Cases Useful for assessing a site's technical health, SEO issues, identify vulnerabilities, and ensure compliance with standards. ###### Useful Links - [Lighthouse Docs](https://developer.chrome.com/docs/lighthouse/) - [Google Page Speed Tools](https://developers.google.com/speed) - [W3 Accessibility Tools](https://www.w3.org/WAI/test-evaluate/) - [Google Search Console](https://search.google.com/search-console) - [SEO Checker](https://www.seobility.net/en/seocheck/) - [PWA Builder](https://www.pwabuilder.com/) Server Location ###### Description The Server Location task determines the physical location of the server hosting a given website based on its IP address. This is done by looking up the IP in a location dat

Issues· 1 open

View all issuesOpen on GitHub
  • #343

    location check always times out: no-cors fetch hangs on restcountries.com redirect

    Updated Sep 16, 2026
  • #229

    Add "Blacklight Query" to External Tools

    Updated Sep 10, 2026
  • #335

    [Email Configuration] DMARC settings shown ✅ with p=none

    Updated Aug 22, 2026
  • #301

    [Feature] "dns-server" job results unclear

    Updated May 9, 2026
  • #272

    Proposal: Comprehensive Documentation Overhaul & User Guide

    Updated Jan 9, 2026
  • #39

    Multilingual versions

    Updated Oct 8, 2023

> Tags

TypeScriptosintprivacysecuritysecurity-tools

No comments yet. Be the first to share.

> Details

PublishedAug 1, 2026
UpdatedSep 30, 2026
Category安全
PricingOpen source

> Related tools

O
OWASP ZAP
开源 Web 应用安全扫描器
O
owasp-wstg-tracker
Simple web app to track OWASP WSTG security testing progress
H
homebridge-mi-gateway-security
XiaoMi Gateway Security plugin for HomeBridge.