kind get clusters command error 125
Author: NoobzikCreated Aug 5, 2026Updated Sep 3, 2026
Labelskind/bug
What happened:
Running the command kind get clusters throw the following error log
using podman due to KIND_EXPERIMENTAL_PROVIDER
enabling experimental podman provider
ERROR: failed to list clusters: command "podman ps -a --filter label=io.x-k8s.kind.cluster --format '{{index .Labels "io.x-k8s.kind.cluster"}}'" failed with error: exit status 125
Command Output: Error: template: ps:1:13: executing "ps" at <index .Labels "io.x-k8s.kind.cluster">: error calling index: cannot index slice/array with type stringWhat you expected to happen: Following the quickstart documentation : https://kind.sigs.k8s.io/docs/user/quick-start/ expected similar results (kind)
How to reproduce it (as minimally and precisely as possible):
- Install podman desktop + cli with rootless configuration
- install podman remote linux in wsl
- create a podman machine
- link the socket to rootless
podman system connection add --default podman-machine-default unix:///mnt/wsl/podman-sockets/podman-machine-default/podman-user.sock - from podman desktop, install kind extension
- create a kind cluster from podman desktop
- install kind in wsl
- try the command
kind get clusters - notice the error
Anything else we need to know?:
- LLM suggest to use the following command instead
podman ps -a --filter label=io.x-k8s.kind.cluster --format '{{.Names}} {{.Labels}}'which provides the following results :
kind-cluster-control-plane io.x-k8s.kind.cluster=kind-cluster,io.x-k8s.kind.role=control-planeOther closed issue that is related :
- https://github.com/kubernetes-sigs/kind/issues/4201
- https://github.com/kubernetes-sigs/kind/issues/3813
Environment:
- kind version: (use
kind version): kind v0.32.0 go1.26.3 linux/amd64 - Runtime info: (use
docker info,podman infoornerdctl info):
Client:
APIVersion: 6.0.2
Built: 1784689140
BuiltTime: Wed Jul 22 05:59:00 2026
GitCommit: b28edb9ad70ce4317dc762ee9ce0a6d081d154e9
GoVersion: go1.26.5
Os: linux
OsArch: linux/amd64
Version: 6.0.2
host:
arch: amd64
buildahVersion: 1.44.1
cdiSpecDirs:
- /etc/cdi
- /var/run/cdi
cgroupControllers:
- cpu
- io
- memory
- pids
cgroupManager: systemd
cgroupVersion: v2
conmon:
package: conmon-2.2.1-2.fc44.x86_64
path: /usr/bin/conmon
version: 'conmon version 2.2.1, commit: '
cpuUtilization:
idlePercent: 98.85
systemPercent: 0.7
userPercent: 0.46
cpus: 16
databaseBackend: sqlite
distribution:
distribution: fedora
variant: podman-machine-os
version: "44"
eventLogger: journald
freeLocks: 2046
hostname: NoobZik-PC
idMappings:
gidmap:
- container_id: 0
host_id: 1000
size: 1
- container_id: 1
host_id: 524288
size: 1000000
uidmap:
- container_id: 0
host_id: 1000
size: 1
- container_id: 1
host_id: 524288
size: 1000000
kernel: 6.18.33.2-microsoft-standard-WSL2
linkmode: dynamic
logDriver: journald
memFree: 12754108416
memTotal: 16728616960
networkBackend: netavark
networkBackendInfo:
backend: netavark
defaultNetwork: podman
dns:
package: aardvark-dns-2.0.0-1.fc44.x86_64
path: /usr/libexec/podman/aardvark-dns
version: aardvark-dns 2.0.0
package: netavark-2.0.0-2.fc44.x86_64
path: /usr/libexec/podman/netavark
version: netavark 2.0.0
ociRuntime:
name: crun
package: crun-1.28-1.fc44.x86_64
path: /usr/bin/crun
version: |-
crun version 1.28
commit: 54f16ffbefcd022bf032af768b5c5ce075c18bfc
rundir: /run/user/1000/crun
spec: 1.0.0
+SYSTEMD +SELINUX +APPARMOR +CAP +SECCOMP +EBPF +CRIU +LIBKRUN +WASM:wasmedge +JSON_C
os: linux
pasta:
executable: /usr/bin/pasta
package: passt-0^20260716.g090d739-2.fc44.x86_64
version: |
pasta 0^20260716.g090d739-2.fc44.x86_64
Copyright Red Hat
GNU General Public License, version 2 or later
<https://www.gnu.org/licenses/old-licenses/gpl-2.0.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
remoteSocket:
exists: true
path: unix:///run/user/1000/podman/podman.sock
rootlessNetworkCmd: pasta
rootlessPortForwarder: rootlessport
security:
apparmorEnabled: false
capabilities: CAP_CHOWN,CAP_DAC_OVERRIDE,CAP_FOWNER,CAP_FSETID,CAP_KILL,CAP_NET_BIND_SERVICE,CAP_SETFCAP,CAP_SETGID,CAP_SETPCAP,CAP_SETUID,CAP_SYS_CHROOT
rootless: true
seccompEnabled: true
seccompProfilePath: /usr/share/containers/seccomp.json
selinuxEnabled: false
serviceIsRemote: true
swapFree: 4294967296
swapTotal: 4294967296
uptime: 1h 33m 9.00s (Approximately 0.04 days)
variant: ""
plugins:
authorization: null
log:
- k8s-file
- none
- passthrough
- journald
network:
- bridge
- macvlan
- ipvlan
volume:
- local
registries:
search:
- docker.io
store:
containerStore:
number: 1
paused: 0
running: 1
stopped: 0
graphDriverName: overlay
graphOptions:
overlay.mountopt: nodev
graphRoot: /home/user/.local/share/containers/storage
graphRootAllocated: 1081101176832
graphRootUsed: 3340308480
graphStatus:
Backing Filesystem: extfs
Native Overlay Diff: "true"
Supports d_type: "true"
Supports shifting: "false"
Supports volatile: "true"
Using metacopy: "false"
imageCopyTmpDir: /var/tmp
imageStore:
number: 2
runRoot: /run/user/1000/containers
transientStore: false
volumePath: /home/user/.local/share/containers/storage/volumes
version:
APIVersion: 6.0.2
BuildOrigin: 'Copr: packit/podman-container-tools-podman-29249'
Built: 1784592000
BuiltTime: Tue Jul 21 03:00:00 2026
GitCommit: b28edb9ad70ce4317dc762ee9ce0a6d081d154e9
GoVersion: go1.26.5-X:nodwarf5
Os: linux
OsArch: linux/amd64
Version: 6.0.2- OS (e.g. from
/etc/os-release): Ubuntu 24.04.1 LTS (WSL) - Kubernetes version: (use
kubectl version): v1.36.3 - Any proxies or other special environment settings?: Podman Windows + WSL, kind command ran from podman wsl (remote) configured as rootless
Source: kubernetes-sigs/kind