Error: netavark: Sysctl error: no such sysctl: net.ipv6.conf.all.forwarding
Author: jkroepkeCreated May 12, 2026Updated Sep 13, 2026
Labelskind/bugarea/provider/podman
What happened:
Running kind with podman provider in a restricted CI environment results into an error on our side:
enabling experimental podman provider
Creating cluster "pipeline" ...
• Ensuring node image (gitlab.example.com/images/ocp-3rd/kindest/node:v1.35.0) ...
✓ Ensuring node image (gitlab.example.com/images/ocp-3rd/kindest/node:v1.35.0)
• Preparing nodes ...
✗ Preparing nodes
Deleted nodes: ["pipeline-control-plane"]
ERROR: failed to create cluster: command "podman run --name pipeline-control-plane --hostname pipeline-control-plane --label io.x-k8s.kind.role=control-plane --privileged --tmpfs /tmp --tmpfs /run --volume d3d7b565b940bcecacd14d0cc9dd993b2aa705bd9ce7d97c6cb9975acde2de65:/var:suid,exec,dev --volume /lib/modules:/lib/modules:ro -e KIND_EXPERIMENTAL_CONTAINERD_SNAPSHOTTER --detach --tty --net kind --label io.x-k8s.kind.cluster=pipeline -e container=podman --cgroupns=private --publish=127.0.0.1:36411:6443/tcp -e KUBECONFIG=/etc/kubernetes/admin.conf gitlab.example.com/images/ocp-3rd/kindest/node:v1.35.0" failed with error: exit status 126
Command Output: Error: netavark: Sysctl error: no such sysctl: net.ipv6.conf.all.forwardingWhat you expected to happen: It should just work
How to reproduce it (as minimally and precisely as possible): N/A (we do not know the detailed configuration on OS)
Anything else we need to know?:
Manually create a podman network
podman network create -d=bridge kind
Solves the issues. It seems that creating a IPv6 podman network does not return an error, while create a container inside a IPv6 enabled network does.
kind always creates an IPv6 network unconditionally.
Environment:
- kind version: (use
kind version): v0.31.0 - Runtime info: (use
docker info,podman infoornerdctl info): 4.9.5 - OS (e.g. from
/etc/os-release): - Kubernetes version: (use
kubectl version): v1.32.3 - Any proxies or other special environment settings?: IPv6 disabled on host?
Source: kubernetes-sigs/kind