AWS Route 53 entries with wildcard "*" are created by external-dns the first time, but every time after that it says "Failed submitting change"
Author: mbandersCreated Nov 21, 2023Updated Sep 19, 2026
Labelskind/buglifecycle/stale
What happened:
Using external-dns chart version 6.28.4, app version 0.14.0.
We are creating AWS Route 53 entries that begin with a wildcard like *.example.whatever.com
external-dns succeeds the first time. It successfully creates an A record, a TXT record, and another TXT record like cname-*.example.whatever.com.
However the next time external-dns runs, a minute later, it prints an error message about that same record:
level=error msg="Failed submitting change (error: InvalidChangeBatch: [Tried to create resource record set [name='\\052.example.whatever.com.', type='A', set-identifier='example'] but it already exists, Tried to create resource record set [name='\\052.example.whatever.com.', type='TXT', set-identifier='example'] but it already exists, Tried to create resource record set [name='cname-\\052.example.whatever.com.', type='TXT', set-identifier='example'] but it already exists]\n\tstatus code: 400, request id: 03672723-3c4c-4b4e-acbc-c4074f620dc4), it will be retried in a separate change batch in the next iteration"So external-dns successfully makes the records once, but then complains about those same records every run after that.
What you expected to happen:
No error messages.
How to reproduce it (as minimally and precisely as possible):
Helm chart ingress:
external-dns.alpha.kubernetes.io/aws-weight=100
external-dns.alpha.kubernetes.io/hostname=\*.example.whatever.com, \*.example2.whatever.com
external-dns.alpha.kubernetes.io/set-identifier=exampleAnything else we need to know?:
Environment:
- External-DNS version (use
external-dns --version): 0.14.0 - DNS provider: AWS Route 53
- Others:
Source: kubernetes-sigs/external-dns