Failed to start dashboard-api node with certification issue
Author: xiangmin2587Created Aug 26, 2025Updated Dec 24, 2025
Labelskind/buglifecycle/rotten
What happened?
I tried to install dashboard 7.13.0 on kubernet 1.33.2 offline.
The api failed to start with secret mismatch issue, may I know what's the issue? does dashboard7.13 support kubernet 1.33?
What did you expect to happen?
the api node can run successfully
How can we reproduce it (as minimally and precisely as possible)?
install the kubenet 1.33.2 download related tar and hemchat from 7.13.0 upload image to my own harbor repo, update helm values with right image repo. Run below helm install command:helm uninstall kubernetes-dashboard -n kubernetes-dashboard
helm upgrade --install kubernetes-dashboard -n kubernetes-dashboard ./kubernetes-dashboard -f /root/kubernetes-dashboard/values.yaml
Anything else we need to know?
No response
What browsers are you seeing the problem on?
No response
Kubernetes Dashboard version
7.13.0
Kubernetes version
1.33.2
Dev environment
No response
Source: kubernetes-retired/dashboard