Pods using gVisor failing to start
What Happened?
I'm using x86_64 with Linux Mint. Minikube version:
minikube version: v1.38.1
commit: c93a4cb9311efc66b90d33ea03f75f2c4120e9b0Starting a pod with gVisor is currently failing. It seems unrelated to https://github.com/kubernetes/minikube/issues/5463, and disabling/re-enabling the addon didn't work, for the reasons I list below.
Using the minikube dashboard, I see the following error message:
Failed to create pod sandbox: rpc error: code = Unknown desc = failed to start sandbox "9c7bdbc4145f3dcdede055555b514eecc8681559a2875c4b9ff9c0d5b9a972de": failed to create containerd task: failed to start shim: start failed: : fork/exec /usr/bin/containerd-shim-runsc-v1: exec format errorThe gVisor pod is indeed running successfully, so I don't think that's the issue.
However, If I run minikube ssh and run cat /usr/bin/containerd-shim-runsc-v1, I get:
<?xml version='1.0' encoding='UTF-8'?><Error><Code>NoSuchKey</Code><Message>The specified key does not exist.</Message><Details>No such object: gvisor/releases/release/latest/x86_64/containerd-shim-runsc-v1</Details></Error>Manually going to the URL http://storage.googleapis.com/gvisor/releases/release/latest/x86_64/containerd-shim-runsc-v1 also gives me a 404. However, you can go back to a previous release and see that the file is still hosted: http://storage.googleapis.com/gvisor/releases/release/20260817.0/x86_64/containerd-shim-runsc-v1
Potential Solution
If you go to the gVisor installation guide: https://gvisor.dev/docs/user_guide/install/, you'll see that the guide asks you to download and unzip a tar file instead of downloading the files individually.
I think a solution would potentially be updating https://github.com/kubernetes/minikube/blob/master/pkg/gvisor/enable.go to unzip the TAR, or allowing us to pin an older version instead of always downloading the latest version.
Attach the log file
Operating System
Other
Driver
Docker
Source: kubernetes/minikube