Baike.dev
All toolsOnline toolsAI codingTrendingOpen sourceNewsSubmit
Log in
< Back to tools
J

json-everything

> 编程语言
Open source

System.Text.Json-based support for all of your JSON needs.

1.3K stars0 likes1 views
WebsiteGitHub

About

System.Text.Json-based support for all of your JSON needs.

What is json-everything?

The primary philosophy behind json-everything is to ensure that common JSON functionality has good support in the System.Text.Json space.

The first step to that is checking whether there exist other projects that support a given function.

If so, that effort likely won't be duplicated here. A bit farther down you'll find a list of other projects that are doing some cool things with JSON.

Otherwise, it's open to consideration for this project.

Playground Documentation Blog Interactive Learning

json-everything.net

docs.json-everything.net

blog.json-everything.net

learn.json-everything.net

Discuss Ask Built with Supported by

What's in the box?

There are actually multiple boxes. Each piece of functionality has been broken out into its own library, so you can pick and choose the one(s) that you need.

All libraries are built to .Net Standard 2.0 and .Net 8, 9, and 10.

JsonSchema.Net

JSON Schema, drafts 6 and higher

JsonSchema.Net.Generation

Generation of schemas from .Net types

JsonSchema.Net.Api

JSON Schema validation for ASP.Net APIs

JsonSchema.Net.Generation.DataAnnotations

Schema generation support for System.ComponentModel.DataAnnotations.

JsonSchema.Net.DataGeneration

Random instance data generation (powered by Bogus)

JsonSchema.Net.Data

A vocabulary for accessing instance and external data

JsonSchema.Net.ArrayExt

A vocabulary for extending array validation

JsonSchema.Net.OpenApi

OpenApi 3.1 vocabulary extension (used by Graeae)

JsonPath.Net

JSON Path (RFC 9535)

JsonPatch.Net

JSON Patch (RFC 6902)

JsonPointer.Net

JSON Pointer (RFC 6901) and Relative JSON Pointer (Specification)

JsonLogic

JsonLogic (Website)

JsonE.Net

JSON-e (Website)

Json.More.Net

General-use extensions that probably should have been included in System.Text.Json[.Nodes] but weren't

Yaml2JsonNode

Conversions between the YAML document model in YamlDotNet and JsonNode (both directions).

All of the above libraries offer complete support for their associated specifications.

Error message translations for JsonSchema.Net available in:

  • Italian it
  • Norwegian nb-NO
  • Polish pl-PL
  • Portuguese pt
  • Russian ru
  • Spanish es
  • Swedish sv-SE
  • Turkish tr-TR

NOTE Each language pack is provided by its own Nuget package.

You can also view JSON Schema Test Suite results on Bowtie, which runs the test suite against multiple implementations across different platforms.

DISCLAIMER My library, JsonSchema.Net, is not related to or associated with the website https://jsonschema.net, except that they are both excellent JSON Schema tools.

Deprecated packages

These packages have also been a part of this suite but are no longer supported.

JsonSchema.Net.CodeGeneration

Generation of C# code from schemas Deprecated in favor of Corvus.JsonSchema

System.Text.Json support by other projects

If you don't find what you're looking for here, please try one of these excellent projects:

  • JsonCons.Net by @danielaparker
    • JSON Pointer
    • JSON Patch
    • JSON Merge Patch
    • JSON Path
    • JMES Path
  • Corvus.JsonSchema by @mwadams
    • JSON Schema validation with a C# code generation focus
  • (more to come)

If you use JSON to do something that is not covered by a library in this suite or one of the above projects, feel free to create a feature issue.

If you maintain or know of another project that extends System.Text.Json to do cool things, I'd like to list it here, so please create a general issue to let me know about it.

Contributing

Please see the Code of Conduct and the CONTRIBUTING file for more information.

Project Funding & Sponsorship

Also ensure the long-term sustainability of this project, some users of the compiled libraries will be required to pay a monthly maintenance fee as specified by the package license. This fee is required to be paid by all organizations or users of any library from this project who generate revenue. You can pay the fee via GitHub Sponsors.

To enact this, an EULA on binary releases is included in Nuget packages published from this project.

For more information on who must pay the fee and other frequently asked questions, please see the Open Source Maintenance Fee organisation page.

.NET Foundation

This project is a .NET Foundation member.

Issues· 0 open

View all issuesOpen on GitHub

No open issues yet, or sync has not completed.

> Tags

C#jsonjson-ejson-logicjson-patch

No comments yet. Be the first to share.

> Details

PublishedAug 1, 2026
UpdatedSep 17, 2026
Category编程语言
PricingOpen source

> Related tools

T
TypeScript
JavaScript 的超集,为前端与全栈提供静态类型
P
Python
通用编程语言,广泛用于 Web、数据与 AI
G
Go
Google 推出的简洁高效系统语言