Error starting cartservice: rosetta error: failed to open elf at /lib64/ld-linux-x86-64.so.2

Author: sergiitomusiakCreated Jul 12, 2026Updated Jul 17, 2026

Describe the bug

When running skaffold run cartservice pod fails to start with the following error:

- deployment/cartservice: container server is backing off waiting to restart
    - pod/cartservice-84585d5cdd-2fjcv: container server is backing off waiting to restart
      > [cartservice-84585d5cdd-2fjcv server] rosetta error: failed to open elf at /lib64/ld-linux-x86-64.so.2
      > [cartservice-84585d5cdd-2fjcv server]
 - deployment/cartservice failed. Error: container server is backing off waiting to restart.

To Reproduce

Run skaffold run

Logs

rosetta error: failed to open elf at /lib64/ld-linux-x86-64.so.2

Environment

OS: MacOS Tahoe 26.3.1 (a) Docker version 29.6.1, build 8900f1d Kubernetes distribution, version: kind, Kubernetes version: v1.36.1

Exposure

Local

Source: GoogleCloudPlatform/microservices-demo