#950·glance

Hangs on startServer failures

Author: ddormerCreated Feb 7, 2026Updated Sep 6, 2026
Labelsbug report

Description

startServer doesn't exit on failure, as seen here. I'm running Glance in a systemd service and can't tell that the server failed to start without an exit code.

Is there existing code that relies on this kind of behaviour? or can an exit call safely be made in the startServer function?

An example of a failure that I'd like to detect, is when the port is already in use: Failed to start server: listen tcp 10.0.0.5:8581: bind: cannot assign requested address