SQlite3 error on 1.10.0
Describe the bug After updating from 1.9.2 to latest 1.10.1 I'm getting the following logs, backrest just won't start and loop on these same 4 lines.
2025-11-01T13:37:27.939+0100 INFO backrest version 1.10.1@b9181dc00d7c595c0ff1eae333c6ecdecee96b74, using log directory: /data/processlogs
2025-11-01T13:37:28.194+0100 INFO restic binary "/bin/restic" in $PATH matches required version 0.18.1, it will be used for backrest commands
2025-11-01T13:37:33.269+0100 WARN operation log may be corrupted, if errors recur delete the file "/data/oplog.sqlite" and restart. Your backups stored in your repos are safe.
2025-11-01T13:37:33.269+0100 FATAL error creating oplog: run multiline query: sqlite3: disk I/O errorI've tried to follow the warning instructions and delete oplog.sqlite but I'm still experiencing the same, the file is recreated but stays blank.
Platform Info
- OS and Architecture: Linux 3.10.108 x86_64 GNU/Linux synology_braswell_716+
- Backrest Version: 1.10.0 and 1.10.1
Additional context Looking at the changes that went into 10.0.0 it seems another library to write the sql is being used, maybe that's where the problem comes from? I'm running backrest on a quite old Synology and so far it has been working great. I would be tempted to say it's a problem with my docker / filesystem setup but it does work well with other containers and also wouldn't explain why it works great on 1.9.2 but not 1.10.1. Moving back to 1.9.2 works again so I've got a fix for now at least. Thanks for the great software and let me know if I can help pin down the issue further.
Source: garethgeorge/backrest