[TRACKING] Breaking changes in Falco 1.0.0
Author: andreaterzoloCreated Jan 29, 2024Updated Sep 13, 2026
Labelskind/documentationlifecycle/stale
This issue keeps track of all deprecated Falco features that will be removed in Falco 1.0.0:
appendin Falco rule is deprecated in favor ofoverride(see https://github.com/falcosecurity/falco/pull/2992)- syntax like is deprecated in favor of
- rule: Write below etc enabled: falseoverride(see https://github.com/falcosecurity/falco/pull/2992).Please note that the- rule: Write below etc enabled: false override: enabled: replaceenabledkey is only deprecated when used as an override! So a rule like this is perfectly legit:- rule: legit_rule desc: legit rule description condition: evt.type=open output: user=%user.name command=%proc.cmdline file=%fd.name priority: INFO enabled: false
Source: falcosecurity/falco