#7251·duplicati

Duplicati 2.3.0.4 on Windows Server 2022/2025 two annoying bugs

Author: szymonn81Created Sep 1, 2026Updated Sep 4, 2026

Version 2.3.0.4_stable_2026-07-09 System : WIndows Server 2022/2025

Hi, Version 2.3.x behaves unstable on Windows server, I tested on 2022 and 2025

Example In Duplicati 2.2 version, installation as a service worked as below, now I get an error and I have to do it differently

Bug 01- Error creating first password Install Duplicati as service Duplicati.WindowsService.exe install --webservice-interface=loopback --webservice-port=8200 --portable-mode --disable-db-encryption=true Duplicati service installation succeeded. Duplicati service started.

Set password Duplicati.CommandLine.ServerUtil change-password --server-datafolder "C:\Program Files\Duplicati 2\data" Connecting to http://127.0.0.1:8200/... Failed to obtain a signin token: Server error (401): Failed to sign in Enter server password: ********* Failed to connect to server: Server error (401): Failed to log in

In version 2.3 I have to install the service with a password and uninstall and reinstall again (why?)

Duplicati.WindowsService.exe install --webservice-interface=loopback --webservice-port=8200 --portable-mode --disable-db-encryption=true --webservice-password=mypassword Duplicati service installation succeeded. Duplicati service started.

Duplicati.WindowsService.exe UNINSTALL Duplicati service delete succeeded.

Duplicati.WindowsService.exe install --webservice-interface=loopback --webservice-port=8200 --portable-mode --disable-db-encryption=true Duplicati service installation succeeded. Duplicati service started.

Bug 02 - Schedule Sometimes you can't set Custom schedule, if you once checked Don't rin automatically then you can't change to Custom