RDS IAM auth
Author: pete911Created Jul 11, 2026Updated Jul 11, 2026
Labelssuggestion
Is your feature request related to a problem? Please describe.
We are using RDS IAM auth, but sftpgo only supports passwords. With IAM auth, token/password is generated via rds build-auth-token.
This token is short lived (15 minutes), so it requires to be implemented in BeforeConnect in postgres/mysql config.
Describe the solution you'd like
New option to use IAM auth where I pass AWS region (everything else e.g. host, port etc. can be retrieved from existing flags).
Describe alternatives you've considered
There is no alternative currently, we can get token on startup, but as soon as sftpgo will acquire new connection after 15 minutes, this connection will be refused.
What are you using SFTPGo for?
Medium business
Additional context
No response
Source: drakkan/sftpgo