Helix failure `EPT_S_NOT_REGISTERED`
Author: amcaseyCreated Aug 19, 2024Updated Sep 17, 2026
Labelstest-failureKnown Build Errorarea-networking
We've been seeing a lot of Helix runs fail with a number of messages related to EPT_S_NOT_REGISTERED:
System.ComponentModel.Win32Exception : The Local Security Authority cannot be contactedSystem.Security.Cryptography.CryptographicException : There are no more endpoints available from the endpoint mapper.The failures only occur on Windows and inconsistently affect subsets of the IIS, HTTPS, Data Protection, and Certificate tests.
AFAICT, EPT_S_NOT_REGISTERED indicates that lsass.exe is not available.
Known Issue Error Message
Fill the error message using step by step known issues guidance.
{
"ErrorMessage": "",
"ErrorPattern": "(Local Security Authority cannot be contacted)|(no more endpoints available)",
"BuildRetry": false,
"ExcludeConsoleLog": false
}Known issue validation
Build: :mag_right: https://dev.azure.com/dnceng-public/public/_build/results?buildId=778691
Error message validated: [(Local Security Authority cannot be contacted)|(no more endpoints available)]
Result validation: :white_check_mark: Known issue matched with the provided build.
Validation performed at: 8/19/2024 8:44:57 PM UTC
Report
Summary
| 24-Hour Hit Count | 7-Day Hit Count | 1-Month Count |
|---|---|---|
| 0 | 0 | 0 |
Source: dotnet/aspnetcore