Baike.dev
All toolsAI codingTrendingOpen sourceNewsSubmit
Log in
Back to tool/Back to issues
#1407·coturn

[Question] Deny TURN own peer IP

Author: cyberaaCreated Jan 26, 2024Updated Mar 18, 2026

Hey guys,

I have the following configuration:

listening-port=80
tls-listening-port=443
no-tlsv1
no-tlsv1_1
listening-ip=10.0.10.5
external-ip=34.100.10.47
fingerprint
lt-cred-mech
user=myuser:mypass
realm=turn.test.com
cert=/etc/certs/fullchain.pem
pkey=/etc/certs/privkey.pem
cipher-list="TLS_AES_128_GCM_SHA256:TLS_AES_256_GCM_SHA384..."
dh-file=/etc/ssl/private/dhparams.pem
no-multicast-peers
no-loopback-peers
no-software-attribute
...
denied-peer-ip=0.0.0.0-0.255.255.255
denied-peer-ip=10.0.0.0-10.255.255.255 # Denies own IP 10.0.10.5

Questions:

  • Is it fine to deny TURN's own IP(10.0.10.5)?
  • Will this still work?
  • Is there any scenario, in which, this will fail?

Reasoning:

I have done this to prevent SSRF attacks by using stunner to tunnel unauthorized HTTP requests to the TURN server.

Observations:

  • I have tested with Tricke ICE tool and I have positive results, however, using other tools like test.8x8.vc, it reported failure in the relay connectivity but not host connectivity.
  • I also have seen other configurations that deny TURN own IP.

Source: coturn/coturn

View original on GitHubView discussion on GitHub