No information or guiding directions after AI & wrong alert on problem with monitoring mongodb.
For al longer time now if an AI request is done there are no guidlines or directions anymore presented. The AI is used with a coroot-cloud-licence (free) and is not stating errors in the settings section anymore.
Second: This error here is kind of strange and seen with more applications while everything is working fine and within normal response times for the application cluster-agent:
Looking at the time this error started these errors came in to the cluster-node logs:
W0827 07:25:42.708542 1 mongo.go:153] mongodb://172.28.0.4:27017 (app=chat-mongodb instance=[email protected] node=zbook-server.localdomain): server selection error: server selection timeout, current topology: { Type: Single, Servers: [{ Addr: 172.28.0.4:27017, Type: Unknown }, ] }
So these errors are possibly related to an mogodb (enabled in coroot) instance that cannot be traced by the cluster-node, but looks like a faulty Alert message on the cluster-agent that's not actually true.
This error was solved by joining the application network of the application by the cluster agent, but I somehow try to see what would be the right place to make the error visible.
Source: coroot/coroot